Hey everyone, a few days ago I plugged in my Phone charger into my van and it started charging my phone for about 5 seconds. After that it started smoking and now the radio will not turn on. I can not play Cd"s or cassette tapes either. It wont even let me use an auxiliary cord to connect to my phone for music. I"m assuming its a blown fuse but I am not sure about that. I found the fuse box in the engine but Ive looked on the internet and every website says that that fuse box doesn"t have anything to do with the electronics on the inside of the vehicle but they don"t say were the other fuse box would be. I have researched more and websites say there is another one but they don"t say where. if you guys no where it is could you please let me know so i can get my radio fixed.




You are watching: 2005 chrysler town and country radio fuse location

Its not a fuse, it is a accessory relay which is located in the fuse box up front that powers the 12 volt outlets and the radio..


I have a 2007 Dodge Grand caravan. The radio , everything is working . All the speakers just stopped working. I"d check the fuses , but where are they !?!?!?


*

*



See more: The Gift Of The Magi Symbols In The Gift Of The Magi Symbols

*

I HAVE SOLVED THE SHORTING OUT PROBLEM OF THE RADIO SHORTING OUT, FLASHING, RESETTING, OR JUST PLAIN NOT WORKING!!! It is in the radio, behind the buttons. After six months of listening fools tell me to connect and disconnect, change fuses, etc, and pulling my hair, i finally removed the radio. using a star set of drivers i removed the front panel of the radio, and then the green board on the back of that panel, looking for dirt or bad connections. i found two flat, square, gold contact points on the green panel. there were tow very thin metal contacts on the button board that corresponded to these contact points. i noticed the metal was bent very far down, so i very gently placed a tiny screwdriver behind the contacts and gently bent them forward, where they would make a better contact with the little squares. i screwed the radio back together, re-installed it, and BAM. worked like a champ. lights, buttons, switches, the works. i"m going to go take a ride now and listen to my radio -- on ALL the stations.