JavaScript is disabled. For a far better experience, please enable JavaScript in your browser prior to proceeding.

You are watching: 2002 ford taurus instrument panel lights


Hello, I have actually a 2002 Ford Taurus, and the lights that light up the dashboard speedometer, rpm gauge, and odometer don"t come on when I turn on the lights in the car. The surrounding warnings and also indicators light up simply fine.We"ve make the efforts looking in the hand-operated for what a fuse does and also then pulling it, trial and error it v a multimeter, and also didn"t find anything the way; but we didn"t try all the fuses and also the car"s documentation is a bit arcane. Perform you recognize which fuses we need to check prior to we dominion this together a burnt-old old-school-Edison light bulb?Here are a couple of photo"s of mine manual, and the casing to my car"s fusebox:
*

*

*

*

*

under the hood examine the 5a red fuses (fuse number 2,5 and 11 iirc)in the vehicle check fuse locations 12,22 and 30. There room a couple of bulbs in the cluster. Lock shouldnt that all burned out at the very same time. Not saying it never ever does however chances space its a fuse. Just since a fuse tests an excellent when pulled doesnt average it is. Occasionally when you pull a fuse the backwards movement will reconnect the break. For this reason pushing it earlier in will open the connection. For this reason make certain you take it a great look in ~ them and test with a dmm
looking at your pics i seem to it is in wrong. 16 and 27 inside and also 32 and 38 under the hood from what i can see in her pics
Picture of my DMM
(Used the logic setup to check the fuses, so the it screens open when using it and shrt when the circuit is closed)
All tested fuses show up to work, although ns couldn"t uncover 38 under the hood reason it wasn"t over there (unless there"s another fusebox ns don"t recognize about).Thanks again, Andrew J. Leer
im sorry.... 38 have to be inside the car.its for the gem and is a long shot, the shouldnt impact the dash lights at all. Room there any other worries going on v the car? the tach works? speedo works? over there is a create up on changing the bulbs because that the dash. Some upgrade the lamp to led. Looks pretty imo. If the fuses test an excellent and the dimmer test good then pulling the dash might be next. Ns would give this thread a little wait and see if anyone has actually run right into this problem before pulling the cluster out.
I would try 16, 27, and maybe 29 in the passenger compartment. Otherwise you have burned out bulbs or a negative harness connector to the tool cluster. Do the revolve signal lights function normally?P.S. I examine my fuses making use of the Ω or diode setting so I have the right to see if they"re partly blown (very rare, but possible). Great ones should read 0 ohms obviously.
I"ve offered the height of the dash a good rap before and a light has come back on before. It"s additionally not that hard to adjust out the dash lights. There"s a great write up on just how do perform it. Take it me about 30 minutes.
i agree. Smack the dash and see if anything changes. If no it looks prefer its time to change the bulb or look for a short.

See more: Where Is The Smokey And The Bandit Truck, Smokey And The Bandit


Does anything take place when you change the swarm dimmer control? (the little "wheel" near the key light switch)
Iirc, part members with early gen4s necessary to bending the copper call strip ~ above the earlier of the instrument cluster, particularly in cooler weather.
Check this subject please: http://www.civicpride-kusatsu.net/forum/82-...01-taurus-instrument-cluster-lights-inop.html
--Nick-"66 Ford country Squire wagon 390/C6-"87 & "89 Mercury nest Park wagons 302 EFI/AOD-"90 Lincoln Town car 302 EFI/AOD-"03 Lincoln Town automobile 4.6L/4R70Wformer "87 Taurus 3.0 GL sedan, "87 Taurus 3.0 GL Wagon, "97 Taurus SHO 3.4 V8 sedan, "00 Taurus SEL 3.0 24V
Same thing happened to me
I had actually the same concern with mine 2001 DOHC taurus i finally found the problem. It was a poor connection with the wiring exploit going to the back of the tool cluster. I unplugged both wiring harnesses and also cleaned them and also wiped the relationships on the earlier of the cluster v a cotton ball and also rubbing alcohol. No much more problems dash lamp up every time now